Minggu, 23 Desember 2007

[Mikrotik] Per Connection Queue (PCQ)

Per Connection Queue (PCQ) is a queuing discipline that can be used to dynamically equalize or shape traffic for multiple users, using little administration. It is possible to divide PCQ scenarios into three major groups: equal bandwidth for a number of users, certain bandwidth equal distribution between users, unknown bandwidth equal distribution between users.

Equal Bandwidth for a Number of Users

Use PCQ type queue when you need to equalize the bandwidth [and set max limit] for a number of users. We will set the 64kbps download and 32kbps upload limits.

Image:PCQ.png

There are two ways how to make this: using mangle and queue trees, or, using simple queues.

1. Mark all packets with packet-mark all:

/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=all passthrough=no


2. Setup two PCQ queue types - one for download and one for upload. dst-address is classifier for user's download traffic, src-address for upload traffic:

/queue type add name="PCQ_download" kind=pcq pcq-rate=64000 pcq-classifier=dst-address
/queue type add name="PCQ_upload" kind=pcq pcq-rate=32000 pcq-classifier=src-address


3. Finally, two queue rules are required, one for download and one for upload:

/queue tree add parent=global-in queue=PCQ_download packet-mark=all
/queue tree add parent=global-out queue=PCQ_upload packet-mark=all

If you don't like using mangle and queue trees, you can skip step 1, do step 2, and step 3 would be to create one simple queue as shown here:

/queue simple add queue=PCQ_upload/PCQ_download target-addresses=192.168.0.0/24

Sabtu, 22 Desember 2007

[Mikrotik]Transparent Traffic Shaper

We will configure one queue limiting the total throughput to the client and three sub-queues that limit HTTP, P2P and all other traffic separately.

Quick Start for Impatient
Configuration snippet from the MikroTik router:

/ interface bridge
add name="bridge1"
/ interface bridge port
add interface=ether2 bridge=bridge1
add interface=ether3 bridge=bridge1

/ ip firewall mangle
add chain=prerouting protocol=tcp dst-port=80 action=mark-connection \
new-connection-mark=http_conn passthrough=yes
add chain=prerouting connection-mark=http_conn action=mark-packet \
new-packet-mark=http passthrough=no
add chain=prerouting p2p=all-p2p action=mark-connection \
new-connection-mark=p2p_conn passthrough=yes
add chain=prerouting connection-mark=p2p_conn action=mark-packet \
new-packet-mark=p2p passthrough=no
add chain=prerouting action=mark-connection new-connection-mark=other_conn \
passthrough=yes
add chain=prerouting connection-mark=other_conn action=mark-packet \
new-packet-mark=other passthrough=no

/ queue simple
add name="main" target-addresses=10.0.0.12/32 max-limit=256000/512000
add name="http" parent=main packet-marks=http max-limit=240000/500000
add name="p2p" parent=main packet-marks=p2p max-limit=64000/64000
add name="other" parent=main packet-marks=other max-limit=128000/128000
[edit] Explanation
Each piece of code is followed by the explanation of what it actually does.

[edit] Bridge
/ interface bridge
add name="bridge1"
/ interface bridge port
add interface=ether2 bridge=bridge1
add interface=ether3 bridge=bridge1
We create a new bridge interface and assign two ethernet interfaces to it. Thus the prospective traffic shaper will be completely transparent to the client.

[edit] Mangle
/ ip firewall mangle
add chain=prerouting protocol=tcp dst-port=80 action=mark-connection \
new-connection-mark=http_conn passthrough=yes
add chain=prerouting connection-mark=http_conn action=mark-packet \
new-packet-mark=http passthrough=no
All traffic destined to TCP port 80 is likely to be HTTP traffic and therefore is being marked with the packet mark http. Note, that the first rule has passthrough=yes while the second one has passthrough=no. (You can obtain additional information about mangle at http://www.mikrotik.com/docs/ros/2.9/ip/mangle)

/ ip firewall mangle
add chain=prerouting p2p=all-p2p action=mark-connection \
new-connection-mark=p2p_conn passthrough=yes
add chain=prerouting connection-mark=p2p_conn action=mark-packet \
new-packet-mark=p2p passthrough=no
add chain=prerouting action=mark-connection new-connection-mark=other_conn \
passthrough=yes
add chain=prerouting connection-mark=other_conn action=mark-packet \
new-packet-mark=other passthrough=noSame as above, P2P traffic is marked with the packet mark p2p and all other traffic is marked with the packet mark other.

[edit] Queues
/ queue simple
add name="main" target-addresses=10.0.0.12/32 max-limit=256000/512000
We create a queue that limits all the traffic going to/from the client (specified by the target-address) to 256k/512k.

/ queue simple
add name="http" parent=main packet-marks=http max-limit=240000/500000
add name="p2p" parent=main packet-marks=p2p max-limit=64000/64000
add name="other" parent=main packet-marks=other max-limit=128000/128000
All sub-queues have the main queue as the parent, thus the aggregate data rate could not exceed limits specified in the main queue. Note, that http queue has higher priority than other queues, meaning that HTTP downloads are prioritized.

2 Lesser Known Ways To Brainstorm For Internet Home Business Keywords

Search Engine Optimization (SEO) doctrine states that you should always find a keyword that has little to no competition and that has high demand so that you can rise to the top of the search engine results and dominate that particular keyword. The problem with the internet home business area is that many people online are creating new websites with the typical keywords like “work from home” and “home business” so as a result it is almost impossible to rise to the top of the search engines or risking having to pay lots of money for pay per click advertising.

Instead of trying to compete with long established websites in the internet home business niche or high paying pay per click advertisers, this article suggests two ways you can think outside of the box and think of new keywords to promote your internet home business and its products.

Motivations and the internet business opportunity

It has been said that if you figure out someone’s motivations well enough, you can determine what he could do. Instead of hitting the “work at home” keyword when promoting your internet business opportunity, why not instead start thinking of reasons why people would join an internet home business. Reasons such as early retirement, starting part time income, quitting the rat race, getting out of debt come to mind. So if you target the reasons why someone would be interested in an internet business opportunity you are in effect targeting your actual online target audience.

So what you could do is write articles on these topics, optimize your websites to these topics with links to your internet home business which fit in with these motivations rather than the run of the mill work at home business websites.

Another way to generate more internet business signups is to hang out at website forums that discuss such things and offer some constructive advice and have a signature that leads to your internet home business website. If people trust your advice on the forums, they are more likely to trust the internet home business that you promote.

Solve health problems

Many internet home businesses have as their products health supplements. The reason for this is that such products are consumable and can be consumed monthly. As a result of this, nearly every internet home business owner selling vitamins either floods the Google Adwords with ads promoting vitamins or builds websites promoting vitamins.

One way around this problem is to find keywords targeting the problem rather than the solution. E.g. Heart attack if you are trying to promote antioxidants. Do some research into the area you are talking about and then either build a website that tells people more information about their health problems or advertise your product via Google Adwords as the solution to such a problem. Your competition may be significantly lower than if you had targeted “Vitamins” directly. So the lower the competition, the potential more money you might make with regards to product sales.

In conclusion, always aim to find these niches and once you do, spend time on Search Engine Optimization in addition to PayperClick advertising and you will find that in the longer run you will make more money online that you would have dreamed with your internet home business.

Rabu, 29 Agustus 2007

URPMI Usage

To install packages on your Mandrake system, you use the urpmi command. The urpmi command will install the requested package(s) along with any dependencies they may require. There are many options that can be used with the urpmi command, I’ll start with a couple examples using the most common options, to give you an idea on the syntax used, and then list all the options. Keep in mind that urpmi is a root command and needs to be run as the root user.
The most common use of urpmi is installing a single package. An example of this is as follows:
Code:
[root@box root]# urpmi mozilla-firefox
The above command will install mozilla-firefox and any dependencies it may require.
You can also install multiple packages at a time by using the following:
Code:
[root@box root]# urpmi mozilla-firefox mozilla-thunderbird gcal
The above command would install those 3 packages and any dependencies required by them.
Another commonly used urpmi command is for updating every package on the system and is as follows:
Code:
[root@box root]# urpmi –auto-select –auto
As you can see, combining options is allowed.
The following are other options that can be used with the urpmi command:
-a With this option, if multiple packages are found matching the request, urpmi will install all of them.
–allow-force When using this option, if an error occurs, urpmi will ask the user if it should continue the installation without checking dependencies. This is not advised and is why urpmi’s default is to exit immediately.
–auto This option allows urpmi to install all required dependencies without stopping and asking if it’s ok to do so. Often used in combination with the –auto-select option.
–auto-select This option looks at your installed packages, looks at what is available in your defined media sources, and then updates any packages that it finds a newer version for.
–best-output This option will cause urpmi to try and use the X interface, if not available, the standard text (cli) interface is used (using rpm-like output).
–bug directory This option creates a bug report and puts it in directory. You have to send a compressed archive of the directory to the urpmi maintainer for the bug to be reported and accepted properly.
–clean This option clears the cache of any rpm’s there. The cache is located in /var/cache/urpmi/rpms
–curl This option causes urpmi to use curl to download the package(s). Using curl is the default.
–env directory Use a different environment directly from a bug report to replay a bug. The directory argument is the as given to the –bug option.
–excludedocs This option will cause the document files to not be installed.
–excludemedia media1,…,mediaN This option causes urpmi not to look at the specified media source(s).
–excludepath string This option will cause urpmi to not install files whose name begins with the defined string.
–force Using this option causes urpmi to assume yes on all questions.
–fuzzy This option will propose all packages partially matching the name given, even if one of the packages matches the given name exactly. (This is the same as -y).
–install-src This installs only the source package (no binary packages will be installed). Note: From what I can tell this option is no longer valid due to mandrake mirrors no longer being setup for urpmi use with the SRPM tree.
–keep With this option, if some dependancies cannot be satisfied, it’ll change the selection of packages in an attempt to keep the existing packages instead of removing them. This generally rejects the upgrade of packages when a dependency error occurs.
–limit-rate rate This option tries to limit the download speed. The rate is given in butes/sec. By default, this option is not active.
–media media1,…,mediaN With this option, urpmi will only look at the specified media for the package(s). Default is to look in all media sources.
–noclean This option causes the downloaded rpm’s to not be removed from the cache directory /var/cache/urpmi/rpms. Default is to remove downloaded/installed rpm’s from cache.
–no-uninstall This option causes urpmi to never ask to uninstall a package, instead it simply aborts. This can be safer in auto mode.
-p This option allows urpmi to search in provides to find a package. This is the default behavior.
-P This option does not allow urpmi to search in provides to find a package. (This is the opposite of the -p option).
–parallel alias This option activates distributed execution of urpmi to other machines. The other machines MUST have urpmi installed on them, but they are not required to have any media sources defined on them. the alias defines which extension module is to be used by urpmi (urpmi-parallel-ka-run or urpmi-parallel-ssh are available) and which machines should be updated. The alias is defined in the file /etc/urpmi/parallel.cfg
–proxy proxyhost[:port1080] Use this option if you need to specify HTTP proxy.
–proxy-user user:password Use this option to specify a user and password for proxy authentication.
-q This option causes quiet mode. When calling rpm no upgrade status will be displayed.
–root directory With this, all operations and scripts will run after chroot(2) and use the file system tree rooted to for rpm install. The rpm database that resides in the rooted tree will be used, but the urpmi configuration from the normal system tree will be used.
-s This option is the same as –src.
–sort-media media1,..mediaN With this option, you specify the order in which media sources should be sorted and looked at by urpmi.
–split-length count This option will split urpmi’s operation into small transactions of at least count packages. The default setting is 1. Setting this to 0 disables splitting into small transactions.
–split-level number This option will split urpmi’s operation into small transactions when the total number of packages to upgrade is greater than the given number. This option is activated by default with a value of 20.
–src name This option will search a source package matching the given name and select all of its dependencies by default, unless –install-src is used in order to install the source package itself. Note: From what I can tell this option is no longer valid due to mandrake mirrors no longer being setup for urpmi use with the SRPM tree.
–synthesis file This option will use the specified file instead of the urpmi database to use in searching for packages and resolving dependencies.
–test This option will cause urpmi to ‘test’ the installation of package(s) but not install the package(s) or modify the system in any way.
–update This option causes urpmi to only look for package(s) and resolve dependencies using media source(s) defined as update source(s). This was defined when adding the media source(s).
-v This option causes urpmi to be more verbose in its output.
–verify-rpm This option will activate or deactivate rpm signature checking. By default this is activated.
–wget By default is used by urpmi for downloading, this option allows you to specify that wget is used instead of curl.
-X This option causes urpmi to use the X interface, meaning it will open a gui window in the X environment.
-y This option is the same as the –fuzzy option.
–update This option causes urpmi to look for the requested package(s) only in the media source defined as an update source.
Other methods of using urpmi
urpmi http://www.some.url/filename.rpm This command will allow you to retrieve and install a rpm from a web site. Dependency resolving will still take place.
urpmi some.filename.rpm This command allows you to install an rpm that you have previously downloaded. You must run the command in the same directory as the rpm file. Dependency resolving still takes place.

Jumat, 24 Agustus 2007

Load Balancing

With NAT and policy routing, with working HTTPS, IM and large downloads

Quick Start for Impatient

Configuration export from the gateway router:


/ ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local comment="" \
disabled=no
add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=wlan2 \
comment="" disabled=no
add address=10.112.0.2/24 network=10.112.0.0 broadcast=10.112.0.255 interface=wlan1 \
comment="" disabled=no
/ ip firewall mangle
add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 \
action=mark-connection new-connection-mark=odd passthrough=yes comment="" \
disabled=no
add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing \
new-routing-mark=odd passthrough=no comment="" disabled=no
add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 \
action=mark-connection new-connection-mark=even passthrough=yes comment="" \
disabled=no
add chain=prerouting in-interface=Local connection-mark=even action=mark-routing \
new-routing-mark=even passthrough=no comment="" disabled=no
/ ip firewall nat
add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.111.0.2 \
to-ports=0-65535 comment="" disabled=no
add chain=srcnat connection-mark=even action=src-nat to-addresses=10.112.0.2 \
to-ports=0-65535 comment="" disabled=no
/ ip route
add dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=255 target-scope=10 routing-mark=odd \
comment="" disabled=no
add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 routing-mark=even \
comment="" disabled=no
add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 comment="" \
disabled=no

Senin, 06 Agustus 2007

Port Filter Mikrotik

/ ip firewall filteradd chain=forward protocol=tcp dst-port=135-139 action=drop comment=”” disabled=no

add chain=forward protocol=udp dst-port=135-139 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=445 action=drop comment=”” disabled=no

add chain=forward protocol=udp dst-port=445 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=593 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=1024-1030 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=1080 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=1214 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=1363 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=1364 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=1368 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=1373 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=1377 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=1433-1434 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=2745 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=2283 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=2535 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=3127 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=3410 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=4444 action=drop comment=”” disabled=no

add chain=forward protocol=udp dst-port=4444 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=5554 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=8866 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=10000 action=drop comment=” disabled=no

add chain=forward protocol=tcp dst-port=10080 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=12345 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=17300 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=27374 action=drop comment=”” disabled=no

add chain=forward protocol=tcp dst-port=65506 action=drop comment=”” disabled=no

MikroTik RouterOS™

MikroTik RouterOS™ turns a standard PC computer into a powerful network router. Just add standard network PC interfaces to expand the router capabilities.
  • Remote control with easy real-time Windows application (WinBox)
  • Telnet/SSH/console/serial console control with RADIUS authentication
  • Advanced bandwidth control
  • Network firewall with packet-filtering, masquerading, network address translation, logging and connection monitoring
  • DHCP support
  • HotSpot gateway with RADIUS authentication
  • Ethernet 10/100/1000Mb/s
  • Wireless client and Access Point 2.4GHz 11Mb/s (IEEE802.11b), 5GHz 54Mb/s (IEEE802.11a) and 2.4GHz 54Mb/s (IEEE802.11g) with RADIUS authentication for AP
  • V.35 synchronous 8.448Mb/s with Sync-PPP, HDLC or Frame Relay
  • X.21 synchronous 8.448Mb/s with Sync-PPP, HDLC or Frame Relay
  • Async PPP (up to 128 ports) with RADIUS authetication for modem pools
  • E1/T1 support
  • IP Telephony Gateway
  • Built-in Web-proxy
  • And much more
  • Sabtu, 04 Agustus 2007

    Google Adsense Page Positioning

    Kenneth Elliott

    Correct positioning of your Google adsense ads can make or break your success with the Google adsense program. Why is this true? Some studies suggest that eye positioning on website gravitate to particular sections of web pages. And if you don’t have the necessary ads in these positions you will not get the clicks.

    I talked to countless people that have great traffic, some with 300 to 1000 new visitors a day that say that they only make approx. at max $10 to $20 dollars a month on the adsense program. What a shame. But when I look at their websites the ads are either buried in wording that no one usually pays attention to or the ads are located in positions that just don’t call any attention to their presence.

    So were the best locations for you Google adsense ads. Well, I have found the number one best place for the ads are near or in proximity to your main menu. Why near your main menu. Because you know that visitors eyes will and always look for the menu structure of your website. So the common places for placement should be to the top right, the very top under your menu, or the top left. These are the most common locations for you main menu.

    But what about the color scheme of the Google adsense ads? Yes, color is very important. You have to make the ads looks as seamless as possible. Here is an example on one of my website http://www.pottery-barn-outlet.com. Here I decided to position the ads at the very top right under my main menu. In direct eye contact. Also, remove the borders; just these two changes will increase your adsense proceeds one hundred percent.

    By using these tactics I was able to increase my adsense click through rate significantly depending on traffic level and people’s interest.

    Take my advice and give it try. I believe you will see a change and hopefully make adsense a more pleasurable experience

    Jumat, 03 Agustus 2007

    Mikrotik Web Proxy Setting for Transparant proxy

    setting transparant web proxy server

    1. first se t web proxy
    / ip web-proxy
    set enabled=yes –>> to make ip web proxy enable
    set src-address=0.0.0.0 –>> to make source address to access web proxy will allow
    set port=8080 –>> to make port for web proxy
    set hostname=”proxy.war.net.id” –>> setting for visble hostname web proxy
    set transparent-proxy=yes –>> make transparant proxy enable
    set parent-proxy=0.0.0.0:0–>> if we used parent proxy x
    set cache-administrator=”support@somethink.org” –>> make set administrator info support
    set max-object-size=4096KiB –>> maximal object can cacth with the proxy server
    set cache-drive=system –>> where drive position that cache wil be saved
    set max-cache-size=unlimited –>> maximal harddrive we used for cache
    set max-ram-cache-size=unlimited –>> maximal ram we used for cache

    2. add nat for redirect port for squid to make transparant

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080 –>> setting can redirect port 80 to 8080 for proxy server
    /ip firewall nat add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=8080 –>> setting can redirect port 3128 to 8080 for proxy server
    /ip firewall nat add chain=dstnat protocol=tcp dst-port=8080 action=redirect to-ports=8080 –>> setting can redirect port 8080 to 8080 for proxy server

    Kamis, 02 Agustus 2007

    MikroTik Wireless Configuration

    Setup uses Safe Mode. It means that all changes that are made during setup
    are reverted in case of error, or if Ctrl-C is used to abort setup. To keep
    changes exit setup using the ‘x’ key.
    [Safe Mode taken]

    Choose options by pressing one of the letters in the left column, before
    dash. Pressing ‘x’ will exit current menu, pressing Enter key will select the
    entry that is marked by an ‘*’. You can abort setup at any time by pressing
    Ctrl-C.

    Entries marked by ‘+’ are already configured.
    Entries marked by ‘-’ cannot be used yet.
    Entries marked by ‘X’ cannot be used without installing additional packages.
    r - reset all router configuration
    + l - load interface driver
    + a - configure ip address and gateway
    d - setup dhcp client
    + s - setup dhcp server
    p - setup pppoe client
    t - setup pptp client
    * x - exit menu
    your choice:
    OR
    [admin@MikroTik] > ip address
    [admin@MikroTik] ip address> add address=192.168.1.1/24 interface=ether1
    [admin@MikroTik] ip address> pr
    # ADDRESS NETWORK BROADCAST INTERFACE
    0 192.168.1.1/24 192.168.1.0 192.168.1.255 ether1
    admin@MikroTik] ip address> /
    [admin@MikroTik] >
    [admin@MikroTik] >interface
    [admin@MikroTik] interface> pr
    Flags: X - disabled, D - dynamic, R - running
    # NAME TYPE RX-RATE TX-RATE MTU
    0 X ether1 ether 0 0 1500
    1 X wlan1 wlan 0 0 1500
    [admin@MikroTik] interface> enable 0
    [admin@MikroTik] interface> enable 1

    [admin@MikroTik] interface> pr
    Flags: X - disabled, D - dynamic, R - running
    # NAME TYPE RX-RATE TX-RATE MTU
    0 R ether1 ether 0 0 1500
    1 X wlan1 wlan 0 0 1500
    [admin@MikroTik] ip address>add address=172.1.2.1/30 interface=wlan1
    [admin@MikroTik] interface eoip>
    [admin@MikroTik] interface eoip>add name=eoip-tunnel1 remote-address=172.1.2.2 tunnel-id=1 disabled=no arp=enabled
    [admin@MikroTik] interface eoip>pr
    Flags: X - disabled, R - running
    0 R name=”eoip-tunnel1″ mtu=1500 mac-address=FE:FD:00:00:00:00 arp=enabled remote-address=172.1.2.2 tunnel-id=1
    [admin@MikroTik] interface eoip>..
    [admin@MikroTik] interface>
    [admin@MikroTik] interface> bridge
    [admin@MikroTik] interface bridge> add name=bridge1
    [admin@MikroTik] interface bridge>pr
    Flags: X - disabled, R - running
    0 R name=”bridge1″ mtu=1500 arp=enabled mac-address=00:00:00:00:00:0 forward-protocols=ip,arp,appletalk,ipx,ipv6,other stp=no priority=32768 ageing-time=5m forward-delay=15s garbage-collection-interval=4s hello-time=2s max-message-age=20s
    [admin@MikroTik] interface bridge>port
    [admin@MikroTik] interface bridge port>pr
    # INTERFACE BRIDGE PRIORITY PATH-COST
    0 ether1 none 128 10
    1 eoip-tunnel1 none 128 10
    2 wlan1 none 128 10
    [admin@MikroTik] interface bridge port>set eoip-tunnel1 bridge=bridge1
    [admin@MikroTik] interface bridge port>set ether1 bridge=bridge1
    [admin@MikroTik] interface bridge port>pr
    # INTERFACE BRIDGE PRIORITY PATH-COST
    0 ether1 bridge1 128 10
    1 eoip-tunnel1 bridge1 128 10
    3 wlan1 none 128 10
    [admin@MikroTik] interface bridge port>.. ..
    [admin@MikroTik] interface>wireless
    [admin@MikroTik] interface wireless>set wlan1 mode=bridge disable-running-check=no band=5ghz frequency=5180 ssid=test1
    Configurration For Mikrotik Station / Client
    [admin@MikroTik] interface eoip>add name=eoip-tunnel1 remote-address=172.1.2.1 tunnel-id=1 disabled=no arp=enabled
    [admin@MikroTik] interface wireless>set wlan1 mode=station disable-running-check=no band=5ghz frequency=5180 ssid=test1
    [admin@MikroTik] interface>pr
    Flags: X - disabled, D - dynamic, R - running
    # NAME TYPE RX-RATE TX-RATE MTU
    0 R ether1 ether 0 0 1500
    1 R bridge1 bridge 0 0 1500
    2 R eoip-tunnel1 eoip-tunnel 0 0 1500
    3 R wlan1 wlan 0 0 1500

    Senin, 30 Juli 2007

    Make a easy Psybnc

    Step by step :
    1. wget http://www.chanary.net/tools/psy.tar.gz <-- get source
    2. tar -zvxf psy.tar.gz <--- extrak the source
    3. cd .psy <--- move to .psy folder
    4. ./config <--- make config
    ./config chanary 6693
    ident = chanary
    port = 6693
    5. ./fuck <-- this for make crontab, becarefull will erase all crontab and make new for psy
    6. ./run <-- running the psy, open mirc set your ident and port

    Make a easy eggdrop bot

    Step by step :

    1. wget http://www.chanary.net/tools/chanarybot.tar.gz <--- get the source

    2. tar -zvxf chanarybot.tar.gz <-- extrak the source

    3. cd .dat <-- move folder to .dat

    4. ./nadya <---- now for config

    ./nadya a.txt OLib otto 815.130.41.667 smsportal ary

    fileconfig = a.txt

    nick bot = OLib

    ident bot = otto

    IP bot = 815.130.41.667

    channel = smsportal (without #)

    5. ./dssl <-- for running the bot

    If your bot join the channel, PV botnick and type

    pass (your pass) <---- for set your

    auth (your pass) <---- for control your bot